Installing Magento Extensions : Troubleshooting

From Moogento How-to Guides
Jump to: navigation, search

Contents

Magento Help

Something unexpected happened?

Try not to worry too much, take a deep breath and read through these common issues and solutions below.

Most issues have been seen before and are quickly fixable or at least revertible-from.

 

"I can't see the module in the configuration settings page"

  • Try deleting your cache manually. Inside your Magento installation folder, go into var folder and rename the cache folder (eg. to cache1). You can delete that renamed folder if everything works afterwards.
  • If there is still nothing showing in the configuration page, you may have missed some files. Please repeat the installation of the extension.

"I see a white screen / 'Mag registry key' error message / I can't reach the admin page"

  • Double check that compilation is turned off SystemToolsCompilationCompilation off.png
  • If you can't access that page any more (eg. if you installed without disabling the compiler) you'll need to manually disable compilation.
  • If you have shell access, run this from the magento site root:
$ php shell/compiler.php disable
You may also need to clear compiled files:
$ php shell/compiler.php clear
  • A quick way to do this, if you don't have shell or database access, is to comment this line in /includes/config.php, from
define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');, to
#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
This exact format is important as one of the compilation scripts looks for it.

"I see a blank SalesOrders page"

  • If you're using Magemaven OrderComment try editing Magemaven_OrderComment > config.xml
Change :
<sales_resource>
  <rewrite>
    <order_grid_collection>Magemaven_OrderComment_Model_Mysql4_Order_Grid_Collection</order_grid_collection>
  </rewrite>
</sales_resource>
To:
<adminhtml>
  <rewrite>
    <sales_order_grid>Magemaven_OrderComment_Block_Adminhtml_Sales_Order_Grid</sales_order_grid>
  </rewrite>
</adminhtml>


"I get a 404 error in the config page"

  • Log out then log in :)

"Action menu options are not appearing"

"I've installed pickPack/shipEasy, cleared the cache & logged out, but no Invoice/Packslip/'Change Status' etc. options are showing up in the 'Mass Action' drop down menu on the Orders page."

  • You probably have another extension installed that is overwriting that menu.
  • A classic is a 'delete orders' extension - if that's you, for simplicity consider if you still need the other extension - usually deleting orders is only used in the Magento setup phase, and once live is no longer needed (it's actually illegal in a lot of the world to delete orders/invoices). If this is the case for you then you can turn off that other extension.
The easiest method is to rename that /app/etc/moduleName.xml to eg. /app/etc/moduleName.xml.off and clear the cache.
  • If it i something that you need to operate at the same time as pickPack/shipEasy please get in touch with your FTP and Magento access details and we’ll work out a solution.

"I can't save the config page"

If, when you click 'Save', nothing happens, you may have a field empty which needs to have a value in.

  • Expand all the sections and check for an error message - if the miscreant one is not expanded then you won't be able to see the warning until you expand that section.

"Just entered the license key, but it's showing 'Not valid'"

Make sure that you have:

  1. Cleared the Magento cache
  2. Logged out then in
  3. Cleared your personal browser cache (hold shift and click refresh in the address bar)

"Just installed, but I get: Error processing your request / Not found"

There has been an error processing your request : Mage registry key x already exists.

or:

Fatal error: x Not found in …/Layout.php on line x

  1. Check that your uploaded file permissions are at least 644.
  2. Check that you have uploaded all the files (and there wasn't eg. an FTP or network issue midway through the upload).
  3. Check your file and folder permissions - the usual cause of this error is incorrect folder permissions, eg. not being able to read.


"Just installed, but I get 'Your cron is not running' warning at the top of the admin screen"

Your Moogento extensions need the Magento cron to run to get all features to work.

They'll still work without it running, but you'll miss some features.

If you don't want to run the cron, you can disable the warning in the config section, but we recommend running it.

magento-cron-not-running.png

If you see this error in your admin, don't panic! All your Moogento extensions will still run, but you'll just be missing out on all features until you get the cron running.

If you've *just* installed an extension, clear the cache to make sure the new cron tasks are lined up.

Not sure what a cron is? It's a regular task run by your server to process pre-planned tasks. Like counting stock, connecting an order from M2Epro with shipEasy, etc. If you see that message, then your Moogento cron task is 95% likely to not be running. The cause of this are either:

  • the Magento cron task is not running at your server, or
  • there's an issue with one of Magento's 'sub-cron tasks' (each extension may add a few of those) which is holding up the others.

The first one needs to be checked at your server. Depending on your level of server-Fu, you may want to go with this next option first: installing AOE Scheduler.


Hide the Cron warning message

If you're sure your cron is running well (see below for helpful tips how to check that), then you can override the check and force-hide the cron warning message.

Just go to SystemConfigMoogento ->Cron Checks and set 'Disable cron-running check?' to 'Yes'. hide-magento-cron-warning.png


Installing AOE Scheduler to check Magento sub-crons

If you think your Magento cron is running we recommend the excellent AOE Scheduler to quickly see if your cron is running.

How to install this? If your MagentoConnect section is available to you (remember that it should usually be restricted-access for security), the easiest way is just to install it there. Just go to the link above, grab the extension key, then go to your System - Magento Connect section, and enter that key. Click install and it should do the work for you.

If you then go back to admin, clear the cache and log out, then come back and check in System, you should see a new option 'Scheduler'.

Check the timeline sub-section for a quick visual guide to your sub-cron jobs. You should see a sea of green if all is ok.

aoe-scheduler-green-grey-lines.png

If you see:

  • an empty grid
  • all grey lines
  • any red lines at all
  • any orange lines

then all is not ok down Magento Town, and you'll want to investigate what's up. If you hover over any of the vertical lines, you'll see a report of each cron sub-job, which might help you to track down the problem.

If AOE Scheduler reports "No heartbeat detected" then it is not running.

aoe-scheduler-orange-lines.png

Things to check if you cron is not running:

  • Check the file permissions on cron.php (if you're using that file) - try changing to 744
  • Check your crontab
    • If you're using cPanel, there's a specific section for Cron Jobs - have a look in there and check you have a line running cron.php or cron.sh every 5-15 minutes)
    • If you have SSH access, this might work for you: sudo nano crontab -e

Setting up Magento cron in cPanel

If your server is using cPanel (such as via the excellent simpleServers) then it's fairly straightforward to check/add your main Magento cron.

  1. Login to your site cPanel
  2. Make a note of your account path (in the example below it's /home/mydomain)
    setting-up-cron-path.png
  3. Click Cron Jobs section:
    magento-accessing-cpanel-cron.png
  4. Check if your cron is already setup - if it is you'll see a line with a link to cron.php or cron.sh
  5. If it's not setup, adding it is easy. We need to tell the server how often to run our script, and the location of the script file.
    As this is cPanel, it hand-holds us with some useful settings.
  6. In the 'Add a New Cron Job' section, click the 'common settings' dropdown, and choose 'Once per 5 minutes' :
    cron-every-5-minutes.png
  7. It should now look like this:
    cron-adding-file-path.png
  8. We now need to tell the server our script is at. The exact script may be different depending on your server, but you can give this a go:
    php -f /home/mydomain/cron.php
    Remember to replace '/home/mydomain' with the value you copied from Step 2 above.
  9. Click the 'Add new cron job' button to create this cron job:
    magento-cron-setup-complete.png
  10. Check that the new task shows up in 'Current Cron Jobs' (at the base of the page):
    magento-checking-cpanel-current-cron-jobs.png
  11. Congratulations, you've now set the main Magento cron to run every 5 minutes.
  12. Go into your Magento cache settings page, and refresh all caches.
  13. Time to put on the kettle.


"When I select 200+ orders in the Sales>Orders grid and 'sE ship'/'PDF Packing Sheet'/etc, Magento times out."

When we process orders with our extensions, we generally need to load the order info for each order into memory.

When we have all orders in memory then we apply sorts, and process the info, build up PDFs in memory, assign the server to complete other tasks, etc.

These all use server resources - primarily memory/cache in the database, and memory to run each process in the server itself.

The more orders you try and process, the more server resources you will use, and the longer it will take to process.

I wouldn't recommend processing more than 200 orders at a time - probably 100 is better, but it does depend on your server setup. If you are getting timeouts, or need to process more orders, then you'll want to assign more memory to the server process running your store, and probably assign bigger database cache & operating space.

You should also check that your process timeout settings are such that they are not shorter than the longest time you're waiting for a process to complete. Eg. if it takes 2 minutes then timeouts, and your server/php/database timeout settings are 2 minutes, then that is probably behind the timeout - try increasing that value for all of them.

If you're not sure how to do that, please check with your server technician, or your host - depending what tech you're running, this may involve a change to my.cnf and php.ini and well as your server config file(s).

You can also check that you have an opcode cache running, and configured correctly. On recent Magento versions this will be something like zendOptimiser, or APC.

You can also setup a database cache system, like Memcached, to speed up repeated database queries.

It should be possible to process hundreds of orders at the same time, but you'll usually need to make sure your installation is setup as above to achieve that.


"I need to set the Magento demo site notice."

If your dev/staging server isn't on an obvious non-live subdomain (eg. dev./stage./etc.) you'll need to make sure it's showing the Magento demo site notice before we authorise the license for use on that domain.

Just set SystemConfigurationDesign -> HTML Head -> Display demo store notice to Yes and clear the cache.

You should see the message appear at the top of all pages.


pickPack (M1):

"I get an error when printing a PDF"

"I get an error printing any PDF"

If you get this error:

Fatal error: Declaration of Zend_Pdf_FileParserDataSource_File::__construct() must be compatible with Zend_Pdf_FileParserDataSource::__construct() in Zend_Pdf_FileParserDataSource_File.php

This is usually a specific PHP/zendPDF conflict.

Try, in lib/Zend/Pdf/FileParserDataSource.php changing

abstract public function __construct();

to

abstract public function __construct($filePath);

"I get an error only with pickPack PDFs"

  • If you've uploaded images (eg. for the logo, shipping address label), please check that they all are non-interlaced, non-transparent, .png files.


"I get an error when printing, that starts with 'Image is not a PNG'"

  • Your image may have the .png ending, but it's not an actual png format file.
  • Re-save the image as a non-interlaced, non-transparent png-8 and you should be fine.
  • If you're using multiple images, disable all of them until you find the culprit.

"I get an error report when printing 'Only non-interlaced images are currently supported'"

  1. Make sure you're using non-interlaced png files for your logo images.
    • If you've uploaded images (eg. for the logo, shipping address label), please check that they all are non-interlaced, non-transparent, .png files.
  2. Delete the logo images from your config page, save, then try again.
  3. If that worked, then upload a new version of your logo image, making sure that you select non-interlaced.
"I get an error 'Cannot create image resource. File not found.'"

This sounds like our image caching code is not able to save an optimized image.

  • Check that your uploaded file permissions are at least 644.
  • Check the permissions of the /media/Moogento/pickPack folder.

"I get this error when making a PDF: 'Temp dir is not good: /tmpTemfdsdfsdfsdfsdfsdfsdfp dir is: /tmp'"

  • This error is generated by the Zend Loader, usually around: /www/dev/lib/Zend}
  • The error possibly needs an edit inside: /lib/Zend/Cache/Backend.php
  • Please contact your host to resolve this one, as the actual change will depend on the server and installed server plugin versions.


"I see tofu or strange characters when printing."

You need to provide your PDFs with a suitable font, [see here] for guidance.


"I can't open a pickPack CSV with non-Roman characters in (eg. Chinese), in Excel"

  1. Check the Data tab in Excel, where you can choose the type of character encoding that Excel will use.
  2. Choose 'From Text' and then select the type of charset you want to import.
Eg. if you have Chinese characters in your product names, you can now see them in Excel.
  • Or just use the excellent & free LibreOffice.


"I get an error when uploading an image (eg. logo)."

If you get an error like this:

Unable to create directory '/media/moogento/pickpack/logo_pack/default

or

Destination folder is not writable or does not exist

  • Check that you are not trying to upload an interlaced image.
  • Check that the image doesn't have transparency set.
  • Try saving a png-8 - zendPDF doesn't work very well with jpegs or gifs.
  • When saving your images in Photoshop be sure to save it as 'non-interlaced .png format', as per the image upload guidelines in the pickPack Guides and config sections.
  • If you still get an error, check the folder ownership and permissions of the folder path mentioned in the error message.
  • Try setting the permissions of /media/moogento/pickpack/ to 774 and see if that helps.
  • Check the owner of those folders, and that it matches the server group that runs your site. (Ie. the user that runs the admin has access to save files)

- If it does, consider setting the permissions back again after uploading your images.

"After uploading an image (eg. logo), the new version is not showing."

Check that you have cleared the image and config caches in SystemCache Management

"The amounts for VAT-registered customers are printing with VAT included."

Check that your server is correctly pulling the VAT information... (May help to check SOAP connection to VAT-verifier if used).

If you have a server-side issue here it may also slow down saving the config page, and even slow down producing PDFs (if your server is using processing cycles to try and connect with something that is not setup).


Prices show incorrectly

Please check first what numbers are showing in the order detail page. The majority of times when people think pickPack is producing incorrect numbers, it's actually something else.

We will always try to show the same numbers that show inside Magento.


"Zebra labels print PPI images incorrect dimensions"

  • Check you're using the correct Photoshop template included in pickPack. We have portrait and landscape versions - check that you're using the correct one.


"My store won't attach PDFs to emails."

For pickPack to connect to your system you need to install the free pickPack Email Attachments extension (available in your downloads section if you have a current-license for pickPack).

If that's not installed then we're not directly affecting your email process.

Make sure you've installed the latest email plugin version, whenever you update pickPack - we regularly change this to integrate with other email plugins.

If you notice that automated emails (eg. if you've set Magento to email an 'Order Complete' email when status changes to Invoiced) have stopped, but manual emails (eg. clicking 'resend email' inside an Order Detail page) work, then you may have an issue with your cron.

For automated emails, the email is not sent right away but is scheduled for later sending. I would check the database table that corresponds to those emails and you'll probably see a list of emails backed up that haven't processed.

When you press the 'resend email' button on the order detail page - it doesn't use scheduled send (via cron), but is sent right away.

In this case I would install the great AOE Scheduler to see if you have any cron issues delaying your email processing.

"I've added the code, but all I see is the attachment code in the emails."

We've seen this happen with one store, where they were trying to only include the PDF, and no other text, in the emails.

If you're trying to achieve the same thing, you need to do two things:

  1. Include this code at least in the transactional email body:
    {{var order.increment_id}}
  2. Modify the attachment code slightly; depending on which PDF you're trying to attach, use either:
    {{attach_invoice({{var order.increment_id}})}}
    or:
    {{attach_packingsheet({{var order.increment_id}})}}


"I can't see the email extension in my downloads section."

You need to be on a currently valid license key to access that.

If you're not on a current key, you'll see the plugin greyed out in your Downloads section. The easiest way to get a previously live key valid is to get on a Maintenance Plan, which you can find details of here.

(This section needs a typically increased level of support, and we need to constantly edit the email plugin to work with the latest versions of the other email plugins out there.)


"After updating an old version, I don't see the PDF generation buttons in the Order Detail pages."

You need to remove a few deprecated files, see the image below for details (you can also remove those folders if they're empty).

magento-pdf-buttons.png


"In the CSV exports I see 'custom' instead of the actual shipping carrier."

You need to setup shipEasy carrier matching

pickPack (M2):

"The admin user is logged out when trying to print PDFs."

This is a Magento issue, related to Github magento2: Issue #5309

Other users have suggested editing the .htaccess or conf file to something like this:

php_value session.cookie_lifetime 86400

php_value session.gc_maxlifetime 86400

and then setting the Admin Session timeout to 86400 in the admin config..

"I have issues printing PDFs."

If you installed with composer you might want to try making vendor/mpdf/mpdf/ttfontdata writable.


shipEasy:

"Importing tracking CSV error - 'Folder not writable or does not exist.'"

Your access permissions are not correct for var/import : either the user/group is not set to permit your Magento running user to access, or your file permissions are not set correctly.


"Scanning Order ID barcodes isn't working."

For some reason your scanner is not picking up the barcode:

  • If you're using a cheap barcode scanner, try a pricier one (seriously!).
  • Laser usually works better than CCD ones.
  • If you're printing the barcodes with pickPack, you can also try increasing the font size of the barcodes in the General section. This should space out the lines a bit more and make them easier for lo-res scanners to read.

"I get an error when trying to save a logo image."

If you get an error like this when trying to save a logo image:

Unable to create directory /media/moogento/pickpack/logo_pack/default

this means that the folder has incorrect permissions assigned - your website cannot save to that folder. In this case, try creating that folder in that path, and if you still have issues try changing permissions on that folder.

"I get this error in admin: HEX color needs to be 6 or 3 digits long."

You've not set the grid colors correctly. This could happen during an upgrade from an older version of shipEasy. Please check that the config sections for grid row colors are set with a 6-character Hex color code.

"After install : SQLSTATE: Column not found: Unknown column (eg. 'szy_tracking_number') in 'field list'."

"After install : Column already exists: 1060 Duplicate column name (eg. 'mkt_order_id')"

This occasionally happens during installation, if there are multiple admin sessions running.

  1. Clear the cache and refresh the page. This often is enough.
  2. If no change, disable all Moogento extensions, clear cache, then enable each, one by one, clearing cache and checking for errors after each.
  3. If no change, restart installation: in the database -> {possible prefix_}core_resource and delete the line : {module_alias}_setup (eg. moogento_shipeasy_setup for shipEasy).

"After install I get this error: Error in file: ...moogento_shipeasy_setup... Syntax error or access violation: 1091 Cant DROP ...; check that column/key exist"

You have probably been installing with multiple admin windows open so several installation processes were started, confusing it. It should resolve itself on cache clear/logout, but try closing all admin windows and logging out/in with just one.

"When I change column widths in the config, it doesn't show in the Grid."

First, check that you have shipEasy grid styling turned on:

magento-grid-styling-shipeasy.png
(We can't edit the column widths if 'Use shipEasy grid styling?' is not set to 'Yes')

If you have already set that, then you probably are running another grid editor which is overriding ours. Only one can win this battle!

shipEasy coexists with most grid editors, but if two different ones are saying 'Use my styles' only one gets to be boss. And we're not pushy :)

"I've made the column 5px wide but it's showing wider."

  • You can't make the width smaller than the minimum width the column filter.
  • You can't make the width smaller than the column title.
You can try, it won't complain, but it just won't go smaller!
  • The column will usually be resized to fit the widest visible entry for that column in the current list of orders displayed.
column-widths.png
Here the 'sku' column has been auto-widened to show the qty ordered.
  • You can set a 'max width' for a few columns to make this sane (eg. product name, order comments)

Ideas:

  • You can set 'Order Date' to show as 'Simple' which will cut down the width used.
  • You can turn off columns that are not used by your process.
  • You can move the 'Action' column to the far left; this might save needing to scroll right.
  • You can use more compact column titles.

"When running a conflict-detector with MDN Advanced Stock it reports a conflict."

If you see this conflict reported: MDN_AdvancedStock_Model_Sales_Order|Moogento_ShipEasy_Model_Sales_Order then we have already worked around it and everything should work fine.

If you want to remove the conflict warning:

  • Comment out this line (should be about line 53) in /app/code/community/MDN/AdvancedStock/etc/config.xml
<!--<order>MDN_AdvancedStock_Model_Sales_Order</order>-->

"I see some missed shipEasy cron jobs."

shipEasy by default sets its crons jobs to be run every minute. If your cron is setup to run slower than every minute, then you'll get some shipEasy crons jobs piling up and some will register as incomplete.

There's two options:

  1. Set your Magento cron to run every minute, or
  2. Go to SystemConfigMoogento > shipEasy > General and set the 'Fill columns every..' to minimum the same as your Magento cron period.

Eg. if your Magento cron is set to run every 2 minutes, set the shipEasy cron to plan to run every 2 minutes as well.

"The Grid Column Config section only has one line"

You might see a lack of column options in the config:

shipeasy-config-options-missing.png

This won't stop shipEasy running, and will only be an issue while editing the column setup.

Two possible reasons here:

  1. file permissions set incorrectly (check they are at least set to readable) and
  2. other extensions using jQuery.

The 2nd one is the most common - these are some of the known conflicting modules:

  • Modulesgarden_Teamandtaskorganizer
  • Rockettheme_TinyMCE
  • Linksync_Linksynceparcel
  • Sm_Matrix

Quick fix

Since you're unlikely to need to constantly edit the column setup, our current recommendation is just to disable the other extension(s) while you edit the column config.

(This won't affect the layout of the columns after re-enabling the other extension(s) and their javascript.)
  1. Disable the other extension(s)
    eg. rename that extension xml file in /app/etc/modules to have a .off suffix (ie. .xml.off)
    * If you're not sure which extension is causing the issues, you'll want to do some trial-and-error
    eg. by disabling all admin 3rd-party modules, and re-enabling until the miscreant is all that remains.
    disabling-extensions.png
  2. Clear cache
    (may need to log out as well)
  3. You now should have access to the full column config section, which should look something like this:
    shipeasy-column-config.png
  4. Make changes as needed in the config
    Check the Grid result matches the layout that you want
  5. Re-enable the other jquery-using extension by removing the '.off' and clearing cache
  6. Log out
  7. You should now have ​your other extension working, and the Orders Grid customised by shipEasy.
  • Using Rockettheme_TinyMCE ?
    • this custom timymce script, together with jQuery, can be disabled in SystemConfigurationRT ROKMAGE MODULES -> TinyMCE -> General -> Enable Tiny MCE for RokMage Extensions

"I use ChannelUnity and I'm missing their CSV export button in the Order Grid."

  1. Find app/code/local/Tradewinds/Channelunity/etc/config.xml
  2. Comment out this code:
    <adminhtml><rewrite><sales_order>Tradewinds_Channelunity_Block_Adminhtml_Sales_Order</sales_order></rewrite></adminhtml>
  3. Refresh the cache, and the button should be back.


"I see a blue screen in the Orders Grid, and/or have issues filtering in the same page."

If you're using the BL_Grid extension as well as shipEasy, you'll want to check that the BL_Grid rewrites are set.

Normally we set these automatically at the time of installation, but sometimes they don't come across.

In this case please check SystemConfigEnhanced Admin Grids -> Base Configuration that these have been set:

advanced-admin-grid-rewrite-magento.png

Here's a list to make it easier to set:

adminhtml/report_*

enhancedgrid/catalog_product_grid

adminhtml/newsletter_subscriber_grid

adminhtml/newsletter_template_grid

adminhtml/system_email_template_grid

adminhtml/sales_order

moogento_core/adminhtml_sales_order

moogento_core/adminhtml_sales_order_grid

  • You might not need all of these, depending on your setup.'


"Using Infortis' UltraMegaMenu I get a javascript error"

"When adding or editing text to the mega-menu blocks, via 'manage categories' > 'select a category' > 'menu', I get a javascript error."

This is related to multiple jquerys being setup to run.

  1. Open /index.php
  2. Find Mage::run($mageRunCode, $mageRunType);
  3. Right above that line, add: Mage::register('infortis_admin_jquery', 1);

"In the tracking column, I see 'custom' instead of the carrier, eg. 'UPS'.

You need to either:


stockEasy:

"Our orders on the Orders Grid are down as 'pending sync'."

Check that your cron is setup and running

"We uninstalled stockEasy (installed on wrong site!) and now we can't edit products"

You need to remove or disable two attributes that stockEasy sets up:

  1. Product attribute: stockeasy_restock_calculation
  2. Category attribute: stockeasy_restock_calculation

"The 'Grid Column Config' section only has one line"

This is a jquery conflict with another extension, please see here for the fix.

Your 'column edit' section should look like this:

stockeasy-grid-edits.png

"I get an error related to stockEasy but don't have it installed."

If, eg. in product detail page, you see something like this:

Warning: include(Mage/Moogento/Stockeasy/Model/Adminhtml/System/Config/Source/Restock.php): failed to open stream: No such file or directory

then you might have previously installed stockEasy, but not removed the database linkups.

This should solve it for you:

  1. Open DB table "mage_eav_attribute"
  2. Delete attributes where frontend_model, backend_model, or attribute_code fields contain "stockeasy"

"I'm not getting all stock reports emailed to me."

Check that you're sending authenticated emails - we have a brief Magento email Guide which might help.

powerLogin

"Since installing powerLogin we have random login issues."

The problem is probably not caused by powerLogin. Check how your domain is configured to work with/without www - eg. maybe 'url with www' is configured as the base url in magento, but you have links that work without 'www'.

In that case, depending on what url you open next, there could be a cookie set that blocked any future login from another other url. (eg. www vs non-www) Solution: Set the correct cookie domain in your system config and then it should work (you may need to clear cookies for changes to take effect).


profitEasy

"I see a blue screen in the Orders Grid, and/or have issues filtering in the same page."

Please see the solution for shipEasy, it's the same grid conflict that is easily resolved.


"I get a 'Requested Payment Method is not available' on Order Detail pages"

This is known issue of magento - you cannot open an order page if the payment method becomes 'not available'.

Eg:

  • a payment module has been uninstalled
  • orders from live site imported into test site, where the test site has different modules
  • orders imported with M2Epro then used on an install without M2Epro (m2epropayment will be set as the payment method)


"I see a '$0' values in the Order Grid profit column"

If you also have the error above, this is the same cause - when we try to save profit data in the order it fails as Magento returns an error for the payment method.


Clean

"I've installed it but don't see any changes."

Check that you're not running any other admin theme (eg. UE Theme, Bubbles, etc). Since we're a nice extension we submit to other rewrites, so you'll need to disable any other theme to get Clean working.


"The 24h dashboard chart is empty."

For the 24h chart to get data, check that in SystemConfigSystem -> Log Enable Log is set to Yes (not Visitors Only).


"I get some js errors in the backend, like 'Uncaught TypeError: jQuery(...).tooltipster is not a function'"

This is a jQuery conflict with another extension you're running.

Try adding these 2 lines:

Mage::register('jqueryLoaded', 1);

Mage::register('infortis_admin_jquery', 1);

to index.php before:

Mage::run($mageRunCode, $mageRunType);


Drip

"I'm missing some admin options in the config section."

If you're running pageSpeed on your server, make sure that you've added this line to the pagespeed.conf file:

# Drip config

pagespeed Disallow "*edit/section/moogento_drip*";

You need to add those to tell pageSpeed to not strip the html comments that we use to set the config sections.


slackCommerce

"I see an error: 'Unable to read response, or response is empty.'"

Your server can't connect to Slack, please check that your firewalls aren't blocking it, and that you have no SSL cert issues on the server.

"Clicking the Test button produces notifications. But, no live notifications come into my Slack channel."

Check that your Magento Cron is running correctly. SlackCommerce uses this to process the various triggers and send them off to Slack.

"I still have issues"

Check log files

  1. First, check the log files. If you haven't turned on logging do so now. SystemAdvancedDeveloper > Log SettingsMagento loggingo.png
    • Try running Magento and then check those log files - the default location is /var/log
    • Add a number to the log filenames to see recent messages only.
  2. Next, check your server log files for errors (location will depend on your server - look for php and server log files).

Disabling extensions

  1. Still problems? Let's turn it off:
  1. Disable the extension by navigating to /app/etc/modules and renaming your the extension xml file, eg from .xml to .xml_off
  2. Clear the cache (if you can't access your backend cache page, just rename /var/cache (eg. to /var/cache1))

"How long will it take to investigate and fix my issue?"

If you've got in touch with a issue or custom work request, we'll get back to you with a rough ETA.

We do all work in the order that they come in, with some sorting based on the Maintenance Plan you're on.

We can't begin the work (or the ETA timer) until we have correct access details, so please make sure you send correct ones.

"Why is my issue resolution ETA not Right Now???!!!"

Estimates for development work are necessarily vague, it may be faster or slower than the ETA we send you.

It takes time to properly investigate bug reports, and plan feature requests, and we're a small team - we go as fast as we can but please don't expect magical instant development work :)

Also worth bearing in mind that we respond to support requests ourselves, so if you email every day for an update then you'll be directly slowing down your issue resolution.

"I found some encrypted portions of code, have I been hacked?"

All our code is open for you to edit.

We do have a couple of small blocks of encrypted code which are part of our licensing system. These need to be left unedited for your extension to work.

If you're worried that you've been hacked and have some unauthorised code, the easiest way to check these specific files is to compare that code with the same file from the extension zip, downloaded from your Moogento account. Note that this code will sometimes change between versions, so make sure you're comparing the same version.


"I stilll have issues!"

  • Drop us a line with your (S)FTP and Magento access details and we'll take a look.
Before getting in touch, please:
  • turn on Magento logging,
  • turn off Magento compilation,
  • provide details of any opcode or db cache systems and their logins,
  • provide the path to your server log files
  • include your order id or license key

"How do I give you Magento access?"

Tried all the suggestions above and need us to take a look? Not sure how to do that?

  1. Log into your Magento site
  2. Copy the URL from the browser and add it to your email to us.
  3. Next go to SystemPermissionsUsers > Add New User
  4. Make a username and password and add that to the email to us.
  5. then click User Role in the left column and assign us the role of Administrator.

Done!

"Where do I find the license key?"

We need your order id or license key before we can help with support. Because, you know. :)

  1. Go to SystemConfigurationMoogento -> (the extension you want help with, eg. pickPack)
  2. Click the 'License' section at the top of the page to expand it.
  3. Copy the value from the 'License Key' field.
  4. Paste that in your email that to us.

magento-license-key-finding-copying.png